メイン

MOVABLE TYPE アーカイブ

Page:  1  |  2  |  3  |  4  |  5  |  6  |  7 

2010年5月 1日

perlモジュールのCrypt::DSAがインストールされたハズなのに、mt-check.cgiでのチェックが通らない!

MTOS 5.01 の mt-check.cgi でチェックすると、インストールされているはずの Crypt::DSA がインストールされていないとなってしまう(まぁ、えぇんとちゃいますか~)によれば、MTのextlib/Math/以下のBigIntとのバージョン依存が起きているらしいです。

で、パスを無効にしてあげれば問題解決になるということなので、念のためリネームして様子を見ようかと思います。

ちなみに…

CPANでインストールされる
Crypt::DSAは、「Crypt-DSA-1.16」
Math::BigIntは、「Math-BigInt-1.89」

MTのextlibでインストールされている
BigInt.pmは、「$VERSION = '1.63';」

ということで、もしかしたらBigInt.pm 1.63に対応するバージョンのCrypt::DSAをインストールすることでも問題を回避できるかもですね。

2009年7月31日

前回、DBD::Pgをインストールするも、MTのmt-check.cgiで何故かクリアできない。
どうやらMTとDBD::Pgのバージョンに問題関係があるらしい。
Movable Typeユーザー・マニュアル: 既知の問題 (制限事項)、3.xのドキュメントですが、この時点でDBD::Pg 1.4でのトラブルが記されている。

Movable Type 3.17 では、DBD::Pg 1.4 のデータベース・ドライバに不具合があるため、DBD::Pg 1.4 をお使いいただけません。

ちなみに、DBD::Pg 1.32以上が条件なのだが…。

ソースからインストールして確認してみた。

OK…DBD-Pg-1.32_1 ** DEVELOPER RELEASE **
OK…DBD-Pg-1.32_2 ** DEVELOPER RELEASE **
OK…DBD-Pg-1.32

1.4から2.5までのソースは見当たらない…

NG…DBD-Pg-2.5.0

NG…DBD-Pg-2.6.0

あきたので飛ばすw

NG…DBD-Pg-2.13.1_7 ** DEVELOPER RELEASE **
NG…DBD-Pg-2.13.1

NG…DBD-Pg-2.14.0
NG…DBD-Pg-2.14.1←現時点での最新版

つまるところ、2.x系は全滅っぽく、MTでDBD::Pgを使う場合、1.32しか選択肢がないってことになるみたい。
CPANでインストールする人は要注意ですね。

こういうの、インストールドキュメントに記載しておいて欲しいですが…。もしかして、うちだけの問題なのかなぁ。

続きを読む "Movable TypeとDBD::Pg" »

2009年1月13日

MTのCAPTCHA認証の使用に合わせて、ImageMagicで使うらしい、gsをインストールしたのだけど、それ以来、Apacheのエラーログに「sh: line 1: gs: command not found」というのが出ていた。
gsのインストール先は、/usr/local/bin/gsだったのですが、どうやら、/usr/bin/gsを期待されていたらしいです。
なので、リンク作成。

sudo ln -s /usr/local/bin/gs /usr/bin/gs

2008年4月 9日

G3(改:G4 500Mhz)のマシンからG4 1.3Ghzのマシンにサーバを移行中。
OSが10.3から10.4になったことや、試行錯誤して組み上がったシステム環境を新たに構築するのに手間取っています。

続きを読む "test" »

2008年3月16日

やっとアップデートしました。

perlモジュールをいくつか追加でインストール

sudo perl -MCPAN -e shell
install IO::Compress::Gzip
install Crypt::DSA

追加していたプラグインのコピー
mt-static/support/のコピー

Page:  1  |  2  |  3  |  4  |  5  |  6  |  7 

カテゴリー

PAMO Menu
イラスト 綾波レイ MIWO 独白 掲示板